Smf veritabanı güncelleme nasıl yapılır?

Başlatan tarantula901, 05 Ağu 2014, 20:15

« önceki - sonraki »

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

tarantula901

Smfde veritabanı güncellemek bazı arkadaşlarımız için zor olduğu düşünülebilir ancak öyle değil aslında çok kolaydır diyebiliriz.

İlk önce yapmamız gerekenler neler yazalım.

1: veritabanı yedeğimizi alalım.

2: Ftp yedeğimizi alalım.

Sonrasında smfnin upgrade dosyalarını bilgisayarımıza indirelim.

Şu linkte : http://download.simplemachines.org/

Large upgrade dosyasını indirelim.

Ardından zipli Large upgrade dosyasının bir klasor olarak açalım.

içinde bulunan

upgrade.php
upgrade_1-0.sql
upgrade_1-1.sql
upgrade_2-0_mysql.sql
upgrade_2-0_postgresql.sql
upgrade_2-0_sqlite.sql

Bu dosyaları ftp anadizine atalım.

sonrasında smf.gen.tr/upgrade.php şeklinde çalıştırın.

Çalıştırdığınızda ftp bilgilerini girebileceğiniz bir alan gelecek bu alanda ftp bilgilerini gireceksiniz girdiğinizde eğer bilgiler doğruysa sitedeki uyeliğiniz kullanıcı adı ve şifrenizi girin. tıklayın.

Açılan sayfada bir kaç ayar mevcut ilk ayar veritabanı yedeği backup şeklinde alınsınmı tıkı ister tıklayın ister tıklamayın size kalmış birşey eğer dbniz yedeklenmesini istiyorsanız tıklayın.


İkinci ise siteyi bakıma almakla ilgili ister bakıma alabilirsiniz.

Diğerleri tıklı olabilir.  Tıklı olacaklarda db güncelleme  simplemachinesin sitenizden aylık bilgi alma ve veritabanınızadaki sessionları silmeye yarar.

bunları tıkladıktan sonra devam dıyoruz ve veritabanınız güncellemeye başlıyor bitinceye kadar bekliyorsunuz.

bitince karşınızda upgrade.php silinsinmi diyor ona tıklayıp ftpdeki upgrade dosyaları silinmiş olacak.

smf güncellemeyi ayrıntılı anlattım. inşallah yararı olur sizlere



Sosyal Öğretmeni

Bu anlatımınızla smf 1 serisinden 2 serisine de geçebilir miyiz?
Çok yer araştırdım birçok yer geçiş hakkında benzer anlatımlar yapmış.

tarantula901


Bu anlatımınızla smf 1 serisinden 2 serisine de geçebilir miyiz?
Çok yer araştırdım birçok yer geçiş hakkında benzer anlatımlar yapmış.



Bu anlatım sadece 2 serisinin veritabanını güncellemek için. 1 serisinden 2 serisine güncellerken ne tür sorunlar çıkar bilemiyorum oyuzden tam olarak birşey diyemem

sosyaldeyince

ben sitemi paket yükler gibi 2.0.8 e güncelledim.. sorun çıkmadı. veritabanını da güncellemem lazım. güncellemek için yazınızı okurken 2.0.9 un çıktığını gördüm. benim 2.0.8 ile ilgili large update dosyalarını bulmam lazım değil mi?

tarantula901

bulmanıza gerek yok admın panelde guncelleme paketını gosterıor sırasıyla 8 9 guncellersınız

sosyaldeyince

#5
03 Eki 2014, 07:16 Son düzenlenme: 03 Eki 2014, 07:19 sosyaldeyince
Kırmızı bir yazı çıktı:
The upgrader found some old or outdated language files, for the forum default language, turkish.

Please make certain you uploaded the new versions of all the files included in the package, even the theme and language files for the default theme.

language files de uyarı var. ben daha önceden language turkishte bir iki değişiklik yapmıştım acaba ondan mı? Mesela Hızlı Yanıt yerine Hızlı Cevap gibi bazı kelimeleri değiştirmiştim.. resimde gönderdim. SKIP deyip bunu geç desem olur mu?

tarantula901

#6
03 Eki 2014, 07:21 Son düzenlenme: 03 Eki 2014, 07:45 tarantula901
dili ingilizce yapıp deneyin yada skip tıklayın

Sosyal Öğretmeni

Güncellemek yaptım tamam site açıldı ama sürümleri karşılaştır dedim forum bakımından yine sürümü eski gösteriyor. aşağıdaki resimleri inceleyin. Yoksa yanlış olanları mı indirdik?

tarantula901

sürümleri boş verin eksik dil dosyaları yoksa sorun yok zaten ekleyeceğin dil dosyasında 208 ise 209 yaparak bu sorunu halledebılırsınız

Sosyal Öğretmeni

Bunların hatası nasıl çözülür?
site açılıyor. Sorun soe hatasına yolo açması seo hatasına yol açtığı için ne yapabiliriz.

tarantula901

dosyalarda hata yok

sadece guncellemelerde sorun acık yada farklı bır sey varsa guncelleme getırılır ve bu guncelleme ıle dosyada guncellenır o dosyalar su anda guncelleme yoksa guncellenmemıs herhangı bır sorun yoktur demektır

Sosyal Öğretmeni

Alıntı
içinde bulunan

upgrade.php
upgrade_1-0.sql
upgrade_1-1.sql
upgrade_2-0_mysql.sql
upgrade_2-0_postgresql.sql
upgrade_2-0_sqlite.sql
bunları yaptım bir ton hata meydana geldi ...

tarantula901

guncellemede sıkıntı vardı ancak yınede guncellendım sitenizi.

Lazım olur dıye yazayım ayrı bir klasor oluşturup oraya smf yenı surum dosyalarını attıktan sonra ayarlar onarı kullanıp guncelleyın guncelledıkten sonra ayarlar onar php kullanmayı unutmayın

ilimdunyasi

gayet yararlı bir makale olmuş ellerine sağlık mehmet kardeşim...

Emre

Bu anlatımınızla smf 1 serisinden 2 serisine de geçebilir miyiz?
Çok yer araştırdım birçok yer geçiş hakkında benzer anlatımlar yapmış.
Geçebilirsin
Vazgeçilmez sandıklarımdan vazgeçtim. Güvendiğim kişilerin güvenilmez olduğunu gördüm. İkiyüzlü suratlar, katı kalpler gördüm. "Bitmez" dediğim sevgilerin tükenişini, Emek verdiğim sevdaların, Düşüncesizce savruluşunu gördüm.
Acele etmiyorum hayat!

Senin; BOYUNUN ÖLÇÜSÜNÜ ALMAK...
Benim ; BOYNUMUN BORCU OLSUN! ! !


Bu site "kalbim" dediğim eşim Özgen'e ithaf edilmiştir